Hot!Issues with the application process

Author
NfalyJarju
New Member
  • Total Posts : 0
  • Joined: 2017/12/25 07:16:36
  • Status: offline
2017/12/26 02:12:01 (permalink)
0

Issues with the application process

Hi everyone, so I've been trying to apply to join the Royal Navy as a RFA engineer apprentice for quiet some time now. I've registered my interest and applied for an application several times now over the past two months. The problem is I didn't actually receive my online application until a whole month later than when I was supposed to. The next problem that I encountered was that once I had completed the initial sign up for the candidate portal, the email requesting me to confirm my email address never came. Instead I received an email which asked me to reset my password. And this was the case, every single time I completed the sign up form. So I raised these issues with a member of the Royal Navy application helpline (0345 607 5555), who assured me that the technical support team had been notified and that they would be working to fix the problem, and that it was all just a matter of waiting until the system could be patched up. My questions are, has anyone else been experiencing these same issues with the online application process? What advice could you give to help me with my situation? Can I apply for the Royal Navy alternatively, as opposed to online?
 
Thank you.
#1

2 Replies Related Threads

    shuggieshark
    New Member
    • Total Posts : 0
    • Joined: 2017/05/23 15:45:19
    • Status: offline
    Re: Issues with the application process 2017/12/31 09:09:50 (permalink)
    0
    Hi my son applied in the summer too and we've never heard anything back. I actually went in to our local Navy careers office but they weren't able to help. He wants to go to Welbeck and the closing date is end of Jan.
    #2
    Paulus
    New Member
    • Total Posts : 0
    • Joined: 2017/12/31 03:05:01
    • Status: offline
    Re: Issues with the application process 2018/01/03 16:20:47 (permalink)
    0
    I am experiencing the same problem. Just spoke with them and they said they will notify the technical team to fix the problem. I've been asked to wait a few days for an email from them.
    #3
    Jump to:
    © 2018 APG vNext Trial Version 5.5